Παρασκευή, 30 Ιουλίου 2010

Άσκηση : Μονοδιάστατος πίνακας

Γράψτε αλγόριθμο που :
α) διαβάζει τις ηλικίες των 320 κατοίκων ενός χωριού και
     τις καταχωρεί σε μονοδιάστατο πίνακα,
β) υπολογίζει το ποσοστό (%) που διαφέρει η μικρότερη από
    τη μεγαλύτερη ηλικία.

Λύση

     Αλγόριθμος ΧΩΡΙΟ
     Για λ από 1 μέχρι 320
           Διάβασε Η[λ]
     Τέλος_επανάληψης
     ΜΑΧ <-- Η[1]
     ΜΙΝ <-- Η[1]
     Για λ από 2 μέχρι 320
           Αν Η[λ] > ΜΑΧ τότε
                 ΜΑΧ <-- Η[λ]
           Τέλος_αν
           Αν Η[λ] < ΜΙΝ τότε
                 ΜΙΝ <-- Η[λ]
           Τέλος_αν
     Τέλος_επανάληψης
     ΠΟΣ <-- 100*(ΜΑΧ-ΜΙΝ)/ΜΙΝ
     Αποτελέσματα // ΠΟΣ //
     Τέλος ΧΩΡΙΟ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου