Τετάρτη, 7 Ιουλίου 2010

Άσκηση: Πρόγραμμα+διαδικασία

Κάποιοι πελάτες στην τράπεζα MONEΥ έχουν επενδύσει
το σύνολο των κεφαλαίων τους σε προθεσμιακές καταθέ-
σεις και μετοχές του ΧΑΑ.
Ι. Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
   α) διαβάζει το ποσό που επένδυσε κάθε πελάτης,
       και το ποσοστό (%) των χρημάτων αυτών που
       τοποθέτησε σε προθεσμιακές καταθέσεις
       (η είσοδος δεδομένων ολοκληρώνεται μόλις
        δοθεί ως ποσό μια μη θετική τιμή ή όταν η
        τιμή εισόδου για το ποσοστό είναι εκτός ορίων),
  β) καλεί κατάλληλη διαδικασία για να υπολογίσει το
      ποσό που διατέθηκε από τον πελάτη για προθεσμιακές
      καταθέσειςκαι για μετοχές,
  γ) εμφανίζει το παραπάνω αποτέλεσμα με κατάλληλα
      διαμορφωμένο μήνυμα,
  δ) υπολογίζει και εμφανίζει:
       * το συνολικό ποσό που επενδύθηκε σε προθεσμιακές
          καταθέσεις,
       * το συνολικό ποσό που επενδύθηκε σε μετοχές.
  ΙΙ. Να γράψετε το υποπρόγραμμα του ερωτήματος β.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΑΣΚ
     ΜΕΤΑΒΛΗΤΕΣ
           ΠΡΑΓΜΑΤΙΚΕΣ:ΠΟΣΟ, ΠΟΣΠΡΟ,
                                         ΠΟΣΜΕΧ, ΧΡΠ, ΧΡΜ,
                                         ΣΥΝΠ, ΣΥΝΜ
     ΑΡΧΗ
            ΣΥΝΠ <-- 0
            ΣΥΝΜ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                 ΔΙΑΒΑΣΕ ΠΟΣΟ
                 ΔΙΑΒΑΣΕ ΠΟΣΠΡΟ
                 ΑΝ (ΠΟΣΟ > 0) ΚΑΙ (ΠΟΣΠΡΟ >= 0) ΚΑΙ 
                         (ΠΟΣΠΡΟ <= 100) ΤΟΤΕ
                     ΚΑΛΕΣΕ ΕΠΕΝΔ(ΠΟΣΟ, ΠΟΣΠΡΟ, ΧΡΠ, ΧΡΜ)
                     ΓΡΑΨΕ 'Προθεσμιακές καταθέσεις :', ΧΡΠ
                     ΓΡΑΨΕ 'Μετοχές : ', ΧΡΜ
                     ΣΥΝΠ <-- ΣΥΝΠ+ΧΡΠ
                     ΣΥΝΜ <-- ΣΥΝΜ+ΧΡΜ
                 ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ (ΠΟΣΟ <= 0) Ή (ΠΟΣΠΡΟ < 0) Ή
                                        (ΠΟΣΠΡΟ > 100)
            ΓΡΑΨΕ 'Συνολικό ποσό προθ/κών :', ΣΥΝΠ
            ΓΡΑΨΕ 'Συνολικό ποσό μετοχών:', ΣΥΝΜ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

    ΔΙΑΔΙΚΑΣΙΑ ΕΠΕΝΔ(ΠΟΣΟ, ΠΟΣ, ΠΡΟ, ΜΕΤ)
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ, ΠΟΣ, ΠΡΟ, ΜΕΤ
    ΑΡΧΗ
          ΠΡΟ <-- ΠΟΣΟ*ΠΟΣ/100
          ΜΕΤ <-- ΠΟΣΟ*(100-ΠΟΣ)/100
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου