Τετάρτη, 21 Ιουλίου 2010

Άσκηση σε μονοδιάστατο πίνακα

Δίνεται πίνακας Ν[670] πραγματικού τύπου. Γράψτε
αλγόριθμο που με δεδομένο τον παραπάνω πίνακα:
α) διαβάζει μια ακέραια τιμή Μ διασφαλίζοντας ότι αυτή
     θα είναι 0 ή 1,
β) υπολογίζει και εμφανίζει:
    * το άθροισμα Ν[1]+Ν[3]+...+Ν[669], αν Μ = 0
    * το γινόμενο Ν[2] Χ Ν[4] Χ ... Χ Ν[670], αν Μ = 1

Λύση

    Αλγόριθμος ΑΣΚ
    Δεδομένα // Ν //
    Αρχή_επανάληψης
        Διάβασε Μ
    Μέχρις_ότου (Μ = 0) Ή (Μ = 1)
    Αν Μ = 0 τότε
         Α <-- 0
         Για λ από 1 μέχρι 669 με_βήμα 2
              Α <-- Α+Ν[λ]
         Τέλος_επανάληψης
         Εμφάνισε Α
    αλλιώς
         Γ <-- 1
         Για λ από 2 μέχρι 670 με_βήμα 2
              Γ <-- Γ*Ν[λ]
         Τέλος_επανάληψης
         Εμφάνισε Γ
    Τέλος_αν
    Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου