Σάββατο, 31 Ιουλίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποιο:
α) διαβάζει τη θερμοκρασία που καταμετρήθηκε στις
     12μμ. σε κάθε πόλη της χώρας (η είσοδος δεδομένων
     ολοκληρώνεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην
     υποβαλλόμενη προς το χρήστη ερώτηση 'Υπάρχει άλλη
     πόλη;')
β) υπολογίζει και εμφανίζει:
    * το ποσοστό (%) των πόλεων που είχαν θερμοκρασία
       πάνω από 32 βαθμούς,
    * το μέσο όρο θερμοκρασίας των πόλεων που είχαν
       στις 12μμ. θερμοκρασία τουλάχιστον 30 βαθμούς.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΘΕΡΜ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: πληθ, φ1, σ, φ2
            ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ, Θ, ΠΟΣ
            ΧΑΡΑΚΤΗΡΕΣ: ΑΠΑΝΤ
      ΑΡΧΗ
            πληθ <-- 0
            φ1 <-- 0
            σ <-- 0
            φ2 <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                 ΔΙΑΒΑΣΕ Θ
                 πληθ <-- πληθ+1
                 ΑΝ Θ > 32 ΤΟΤΕ
                      φ1 <-- φ1+1
                 ΤΕΛΟΣ_ΑΝ
                 ΑΝ Θ >= 30 ΤΟΤΕ
                      σ <-- σ+Θ
                      φ2 <-- φ2+1
                 ΤΕΛΟΣ_ΑΝ
                 ΓΡΑΨΕ 'Υπάρχει άλλη πόλη;'
                 ΔΙΑΒΑΣΕ ΑΠΑΝΤ
            ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤ = 'ΟΧΙ'
            ΠΟΣ <-- 100*φ1/πληθ
            ΓΡΑΨΕ ΠΟΣ
            ΑΝ φ2 > 0 ΤΟΤΕ
                  ΜΟ <-- σ/φ2
                  ΓΡΑΨΕ ΜΟ
            ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Δεν βρέθηκε καμία πόλη με Θ >= 30'
            ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου