Πέμπτη, 29 Ιουλίου 2010

Άσκηση : Πρόγραμμα+διαδικασία

α) Γράψτε διαδικασία που δέχεται ως παράμετρο
     ένα ακέραιο σύνολο δευτερολέπτων και υπολογίζει
     πόσες ώρες, λεπτά και δευτερόλεπτα περιλαμβάνει
     αυτό το σύνολο.
β) Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
    * διαβάζει τη συνολική διάρκεια σε δευτερόλεπτα
       11 ταινιών,
    * υπολογίζει και εμφανίζει πόσες ώρες, λεπτά και
       δευτερόλεπτα διαρκεί η κάθε ταινία.
Παρατήρηση : Το πρόγραμμα πρέπει να καλεί με
κατάλληλο τρόπο τη διαδικασία που γράψατε στο α).

Λύση

      ΠΡΟΓΡΑΜΜΑ ΤΑΙΝ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: κ, Χρ, Ω, Λ, Δ
      ΑΡΧΗ
             ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 11
                  ΔΙΑΒΑΣΕ Χρ
                  ΚΑΛΕΣΕ Διάρκεια(Χρ, Ω, Λ, Δ)
                  ΓΡΑΨΕ 'Η χρονική διάρκεια της ',κ, ' ταινίας είναι:'
                  ΓΡΑΨΕ Ω, ':', Λ, ':', Δ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

      ΔΙΑΔΙΚΑΣΙΑ Διάρκεια(Χρ, Ω, Λ, Δ)
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Χρ, Ω, Λ, Δ
      ΑΡΧΗ
            Ω <-- Χρ DIV 3600
            Λ <-- (Χρ MOD 3600) DIV 60
            Δ <-- (Χρ MOD 3600) MOD 60
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου