Παρασκευή, 23 Ιουλίου 2010

Άσκηση : Μετατροπές

Ξαναγράψτε το παρακάτω σύνολο εντολών
       Για λ από 2 μέχρι 23 με_βήμα 11
         Διάβασε ψ
         Αν ψ < 10 τότε
               ζ <-- ψ+34
         αλλιώς
                Αν ψ < 21 τότε
                     ζ <-- ζ-1
                αλλιώς
                     ζ <-- ζ+99
                Τέλος_αν
          Τέλος_αν
          Εμφάνισε ζ
    Τέλος_επανάληψης
αντικαθιστώντας :
α) την Για..από..μέχρι με Μέχρις_ότου
β) τις εμφωλευμένες Αν..τότε..αλλιώς με Αν..τότε

Λύση

    λ <-- 2
    Αρχή_επανάληψης
        Διάβασε ψ
        Αν ψ < 10 τότε
               ζ <-- ψ+34
        Τέλος_αν
        Αν (ψ >= 10) ΚΑΙ (ψ < 21) τότε
               ζ <-- ζ-1
        Τέλος_αν
        Αν ψ >= 21 τότε         
               ζ <-- ζ+99
        Τέλος_αν
        Εμφάνισε ζ
        λ <-- λ+11
    Μέχρις_ότου λ > 23

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου