Σάββατο, 24 Ιουλίου 2010

Λύσεις Επαναληπτικών Απολυτήριων εξετάσεων Γ' τάξης Ημερήσιου Γενικού Λυκείου 2010

ΘΕΜΑ Α
Α1.
    1. ΑΛΗΘΗΣ
    2. ΑΛΗΘΗΣ
    3. ΨΕΥΔΗΣ
    4. ΑΛΗΘΗΣ
    5. ΨΕΥΔΗΣ
    6. ΑΛΗΘΗΣ
    7. ΨΕΥΔΗΣ

Α2.
     ΑΝ (βαθμολογία >= 17) ΚΑΙ (βαθμολογία <= 20) ΤΟΤΕ
          ΓΡΑΨΕ 'ΑΡΙΣΤΑ'
     ΑΛΛΙΩΣ_ΑΝ βαθμολογία >= 15 ΤΟΤΕ
          ΓΡΑΨΕ 'ΠΟΛΥ ΚΑΛΑ'
     ΑΛΛΙΩΣ_ΑΝ βαθμολογία >= 13 ΤΟΤΕ
          ΓΡΑΨΕ 'ΚΑΛΑ'
     ΑΛΛΙΩΣ_ΑΝ βαθμολογία >= 10  ΤΟΤΕ
          ΓΡΑΨΕ 'ΜΕΤΡΙΑ'
     ΑΛΛΙΩΣ
          ΓΡΑΨΕ 'ΑΠΟΡΡΙΠΤΕΤΑΙ'
     ΤΕΛΟΣ_ΑΝ

Α3.
      ΠΡΟΓΡΑΜΜΑ Π3
      ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[5, 7], Κ, Ρ
           ΠΡΑΓΜΑΤΙΚΕΣ: Β[10], Χ
      ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5
               ΓΙΑ Ρ ΑΠΟ 1 ΜΕΧΡΙ 7
                     Α[Κ, Ρ] <-- Κ+Ρ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           Χ <-- 300
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 10
                Β[Κ] <-- Χ
                Χ <-- Χ/2
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Α4. Βλέπε σχολικό βιβλίο, σελ. 220

Α5. Βλέπε σχολικό βιβλίο, σελ. 60

ΘΕΜΑ Β

Β1.


Β2. 
          αριθμός              x                  y                 z
          γραμμής
                1                  150              35
                5                                                          35
                8                                                          10
                9                   35
              10                                       10
                8                                                           5
                9                   10
              10                                        5
                8                                                           0
                9                     5
              10                                        0

Β3.
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              z <-- x MOD y
              x <-- y
              y <-- z
        ΜΕΧΡΙΣ_ΟΤΟΥ z = 0 

ΘΕΜΑ Γ

     ΔΙΑΔΙΚΑΣΙΑ ΕΛΕΓΧΟΣ(Χ)
     ΜΕΤΑΒΛΗΤΕΣ
           ΧΑΡΑΚΤΗΡΕΣ: Χ[1000, 3], ΟΝ, ΣΥΝΘ, Ν1, Ν2
           ΑΚΕΡΑΙΕΣ: ΑΑ, Κ
           ΛΟΓΙΚΕΣ: ΒΡΕΘ
     ΑΡΧΗ
           ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΔΙΑΒΑΣΕ ΟΝ
                ΔΙΑΒΑΣΕ ΣΥΝΘ
                ΒΡΕΘ <-- ΨΕΥΔΗΣ
                Κ <-- 1
                ΟΣΟ (Κ <= 1000) ΚΑΙ (ΒΡΕΘ = ΨΕΥΔΗΣ)
                                                       ΕΠΑΝΑΛΑΒΕ
                       ΑΝ (Χ[Κ, 1] = ΟΝ) ΚΑΙ (Χ[Κ, 2] = ΣΥΝΘ) ΤΟΤΕ
                             ΒΡΕΘ <-- ΑΛΗΘΗΣ
                             ΑΑ <-- Κ
                       ΑΛΛΙΩΣ
                             Κ <-- Κ+1
                       ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΑΝ ΒΡΕΘ = ΨΕΥΔΗΣ ΤΟΤΕ
                      ΓΡΑΨΕ 'ΛΑΘΟΣ ΟΝΟΜΑ ΠΡΟΣΒΑΣΗΣ Ή ΣΥΝΘΗΜΑΤΙΚΟ'
                ΤΕΛΟΣ_ΑΝ
           ΜΕΧΡΙΣ_ΟΤΟΥ ΒΡΕΘ = ΑΛΗΘΗΣ
           ΓΡΑΨΕ 'ΚΑΛΩΣ ΗΡΘΑΤΕ'
           ΑΝ Χ[ΑΑ, 3] = 'Α' ΤΟΤΕ
                ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                      ΔΙΑΒΑΣΕ Ν1
                      ΔΙΑΒΑΣΕ Ν2
                ΜΕΧΡΙΣ_ΟΤΟΥ Ν1 = Ν2
                Χ[ΑΑ, 2] <-- Ν1
                Χ[ΑΑ, 3] <-- 'Σ'
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΘΕΜΑ Δ
     
     Αλγόριθμος ΘΕΜΑ_Δ
     Δεδομένα // Μ //
     Μολ <-- 0
     Για κ από 1 μέχρι 5000
          Αν Μ[κ] = -1 τότε
               Μολ <-- Μολ+1
          Τέλος_αν
     Τέλος_επανάληψης
     Εμφάνισε 'Πλήθος μολυσμένων :', Μολ
      Αν  Μ[1] = 0 τότε
            Αν Μ[2] = -1 τότε
                 Μ[1] <-- 1
            Τέλος_αν
     Τέλος_αν
     Για κ από 2 μέχρι 4999 τότε
            Αν Μ[κ] = 0 τότε
                Αν Μ[κ-1] = -1 τότε
                     Μ[κ] <-- Μ[κ]+1
                Τέλος_αν
                Αν Μ[κ+1] = -1 τότε
                     Μ[κ] <-- Μ[κ]+1
                Τέλος_αν
            Τέλος_αν
     Τέλος_επανάληψης
     Αν Μ[5000] = 0 τότε
          Αν Μ[4999] = -1 τότε
               Μ[5000] <-- 1
          Τέλος_αν
     Τέλος_αν
     Πληθ <-- 0
     ΒΡΕΘ <-- Ψευδής
     κ <-- 1
     Όσο (κ <= 5000) ΚΑΙ (ΒΡΕΘ = Ψευδής) επανάλαβε
           Αν Μ[κ] = -1 τότε
                Πληθ <-- Πληθ+1
           αλλιώς
                Πληθ <-- 0
           Τέλος_αν
           Αν Πληθ = 2 τότε
                 ΒΡΕΘ <-- Αληθής
                 Θ <-- κ-1
           Τέλος_αν
           Κ <-- Κ+1
     Τέλος_επανάληψης
     Αν ΒΡΕΘ = Αληθής τότε
          Εμφάνισε  'Υπάρχει σημαντική εστία μόλυνσης', Θ
     αλλιώς
          Εμφάνισε 'Δεν υπάρχει σημαντική εστία μόλυνσης'
     Τέλος_αν
     Αποτελέσματα // Μ //
     Τέλος ΘΕΜΑ_Δ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου