Δευτέρα, 19 Ιουλίου 2010

Άσκηση : Φρουρός

Γράψτε αλγόριθμο που διαβάζει το όνομα και το
επώνυμο των καθηγητών ενός γυμνασίου (η είσοδος
ολοκληρώνεται μόλις δοθεί ως όνομα ή ως επίθετο
το κενό διάστημα), υπολογίζει και εμφανίζει:
α) πόσοι καθηγητές έχουν το όνομα 'Νίκος',
β) το ποσοστό (%) των καθηγητών που έχουν το επώνυμο
     'Καρύδης'.

Λύση

     Αλγόριθμος Γυμνάσιο
     Νικ <-- 0
     Καρ <-- 0
     Πληθ <-- 0
     Αρχή_επανάληψης
          Διάβασε Ον
          Διάβασε Επ
          Αν (Ον < > '   ') ΚΑΙ (Επ < > '   ') τότε
                 Πληθ <-- Πληθ+1
                 Αν Ον = 'Νίκος' τότε
                       Νικ <-- Νικ+1
                 Τέλος_αν
                 Αν Επ = 'Καρύδης' τότε
                       Καρ <-- Καρ+1
                 Τέλος_αν
          Τέλος_αν
     Μέχρις_ότου (Ον = '  ') Ή (Επ = '  ')
     Αν Πληθ > 0 τότε
           ΠοσΚαρ <-- 100*Καρ/Πληθ
           Εμφάνισε Νικ, ΠοσΚαρ
     αλλιώς
            Εμφάνισε 'Δε δόθηκαν δεδομένα'
     Τέλος_αν
     Τέλος Γυμνάσιο

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου