Παρασκευή, 30 Ιουλίου 2010

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο το
μέγεθος μιας γωνίας και υπολογίζει το ημίτονο, το
συνημίτονο, την εφαπτομένη και τη συνεφαπτομένη
της γωνίας αυτής.
Παρατήρηση: Αν η εφαπτομένη ή η συνεφαπτομένη
της γωνίας δεν ορίζονται, στις αντίστοιχες παραμέτρους
αποτελέσματος εκχωρείται η τιμή -1000.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΤΡΙΓ_ΜΕΓΕΘΗ(Γ, ΗΜΓ, ΣΥΝΓ, ΕΦΓ, ΣΦΓ)
     ΜΕΤΑΒΛΗΤΕΣ
            ΠΡΑΓΜΑΤΙΚΕΣ: Γ, ΗΜΓ, ΣΥΝΓ, ΕΦΓ, ΣΦΓ
     ΑΡΧΗ
            ΗΜΓ <-- ΗΜ(Γ)
            ΣΥΝΓ <-- ΣΥΝ(Γ)
            ΑΝ ΣΥΝΓ < > 0 ΤΟΤΕ
                   ΕΦΓ <-- ΗΜΓ/ΣΥΝΓ
            ΑΛΛΙΩΣ
                   ΕΦΓ <-- -1000
            ΤΕΛΟΣ_ΑΝ
            ΑΝ ΗΜΓ < > 0 ΤΟΤΕ
                   ΣΦΓ <-- ΣΥΝΓ/ΗΜΓ
            ΑΛΛΙΩΣ
                   ΣΦΓ <-- -1000
            ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου