Δευτέρα, 26 Ιουλίου 2010

Άσκηση : Φρουρός

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει τις τιμές πώλησης κάποιων
    παιχνιδιών (η είσοδος τερματίζεται μόλις
    δοθεί ως τιμή πώλησης ένας μη θετικός
    αριθμός),
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των παιχνιδιών,
    * το συνολικό κόστος τους,
    * τον αύξοντα αριθμό του ακριβότερου
       παιχνιδιού,
    * το ποσοστό (%) των παιχνιδιών με
       τιμή πώλησης μεγαλύτερη από 20 ευρώ,
    * τη μέση τιμή πώλησης των παιχνιδιών.

Λύση

     ΠΡΟΓΡΑΜΜΑ ΠΑΙΧΝΙΔΙΑ
     ΜΕΤΑΒΛΗΤΕΣ
           ΠΡΑΓΜΑΤΙΚΕΣ: Τιμή, ΠΟΣ, ΜΟ, ΑΘΡ, ΜΑΧ
           ΑΚΕΡΑΙΕΣ: Πλήθος,  Φ, ΝοΜΑΧ
     ΑΡΧΗ
           ΑΘΡ <-- 0
           Πλήθος <-- 0
           Φ <-- 0
           ΜΑΧ <-- -1000
           ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                 ΔΙΑΒΑΣΕ Τιμή
                 ΑΝ Τιμή > 0 ΤΟΤΕ
                      Πλήθος <-- Πλήθος+1
                      ΑΘΡ <-- ΑΘΡ+Τιμή
                      ΑΝ Τιμή > ΜΑΧ ΤΟΤΕ
                             ΜΑΧ <-- Τιμή
                             ΝοΜΑΧ <-- Πλήθος
                      ΤΕΛΟΣ_ΑΝ
                      ΑΝ Τιμή > 20 ΤΟΤΕ
                             Φ <-- Φ+1
                      ΤΕΛΟΣ_ΑΝ
                 ΤΕΛΟΣ_ΑΝ
           ΜΕΧΡΙΣ_ΟΤΟΥ Τιμή <= 0
           ΑΝ Πλήθος > 0 ΤΟΤΕ
                 ΜΟ <-- ΑΘΡ/Πλήθος
                 ΠΟΣ <-- 100*Φ/Πλήθος
                 ΓΡΑΨΕ Πλήθος, ΑΘΡ, ΝοΜΑΧ, ΠΟΣ, ΜΟ
           ΑΛΛΙΩΣ
                 ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα!'
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου