Κυριακή, 18 Ιουλίου 2010

Άσκηση : Ποιά είναι η τελική τιμή της μεταβλητής ζ

Ποιά είναι η τελική τιμή της μεταβλητής ζ μετά την
εκτέλεση των παρακάτω εντολών;
    ζ <-- 101
    Για λ από 1 μέχρι 20
         Αν λ mod 2 = 0 τότε
              ζ <-- ζ-8
         αλλιώς
              ζ <-- ζ+5
         Τέλος_αν
    Τέλος_επανάληψης

Απάντηση

    Παρατηρούμε ότι όταν το λ είναι άρτιο, αφαιρούμε από την
    τρέχουσα τιμή του ζ το 8, ενώ αν το λ είναι περιττό προσθέ-
    τουμε στο ζ το 5. Αφού ανάμεσα στο 1 και στο 20 υπάρχουν
    10 άρτιοι και 10 περιττοί αριθμοί, η τελική τιμή του ζ είναι:
        101-10*8+10*5 = 101-80+50 = 71

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου