Δευτέρα, 26 Ιουλίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που :
α) διαβάζει τα ονόματα και τα ύψη βουνοκορφών της Ευρώπης
    (η είσοδος τερματίζεται μόλις δοθεί η απάντηση 'Ο' στην υπο-
    βαλλόμενη προς το χρήστη ερώτηση 'Υπάρχει άλλη βουνοκορφή
    προς επεξεργασία;'),
β) υπολογίζει και εμφανίζει:
    * το πλήθος των βουνοκορφών που επεξεργαστήκατε,
    * το όνομα της χαμηλότερης βουνοκορφής,
    * πόσες βουνοκορφές είχαν ύψος τουλάχιστον 1000 μέτρα.
Παρατήρηση: Ο αλγόριθμος πρέπει να διασφαλίζει την εγκυρό-
τητα των εισερχόμενων δεδομένων και συγκεκριμένα ότι:
  * τα ονόματα είναι διάφορα του κενού διαστήματος,
  * τα ύψη των βουνοκορφών είναι θετικοί αριθμοί που δεν
     υπερβαίνουν το 2000.

Λύση

     Αλγόριθμος ΒΟΥΝΑ
     Πληθ <-- 0
     ΜΙΚ <-- 2001
     Φ <-- 0
     Αρχή_επανάληψης
         Αρχή_επανάληψης
             Διάβασε ΟΝ
         Μέχρις_ότου ΟΝ < > '   '
         Αρχή_επανάληψης
             Διάβασε Ύψος
         Μέχρις_ότου (Ύψος > 0) ΚΑΙ (Ύψος <= 1200)
         Πληθ <--  Πληθ+1
         Αν Ύψος < ΜΙΚ τότε
              ΜΙΚ <-- Ύψος
              ΟΝΜΙΚ <-- ΟΝ
         Τέλος_αν
         Αν ΄Υψος >= 1000 τότε
               Φ <-- Φ+1
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλη βουνοκορφή προς επεξεργασία;'
         Διάβασε Απ
     Μέχρις_ότου Απ = 'Ο'
     Εμφάνισε Πληθ, ΟΝΜΙΚ, Φ
     Τέλος ΒΟΥΝΑ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου