Σάββατο, 24 Ιουλίου 2010

Άσκηση: Επεξεργασία δοσμένου πλήθους δεδομένων (προϋποθέτει τη χρήση πίνακα)

Γράψτε πρόγραμμα το οποίο:
α) διαβάζει τα ονόματα κάποιων οδών της πόλης σας
     (η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί
      ως όνομα το κενό διάστημα ή όταν το συνολικό
      πλήθος των ονομάτων που έχει δοθεί γίνει ίσο με 20),
β) εμφανίζει τα παραπάνω ονόματα οδών με ανάποδη
    σειρά.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΟΔΟΙ
      ΜΕΤΑΒΛΗΤΕΣ
            ΧΑΡΑΚΤΗΡΕΣ: ΟΔ[20], ΟΝ
            ΑΚΕΡΑΙΕΣ: Πληθ, Κ
      ΑΡΧΗ
            Πληθ <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  ΔΙΑΒΑΣΕ ΟΝ
                  ΑΝ ΟΝ < > '   ' ΤΟΤΕ
                       Πληθ <-- Πληθ+1
                       ΟΔ[Πληθ] <-- ΟΝ
                  ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ (Πληθ = 20) Ή (ΟΝ = '   ')
            ΑΝ Πληθ > 0 ΤΟΤΕ
                   ΓΙΑ Κ ΑΠΟ Πληθ ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -1
                        ΓΡΑΨΕ ΟΔ[Κ]
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΛΛΙΩΣ
                   ΓΡΑΨΕ 'Δε δόθηκαν καθόλου δεδομένα!'
            ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου