Τετάρτη, 21 Ιουλίου 2010

Άσκηση: Επεξεργασία δοσμένου πλήθους δεδομένων (με χρήση πίνακα)

Γράψτε αλγόριθμο που:
α) διαβάζει τα έτη γέννησης 120 ατόμων,
β) υπολογίζει τις ηλικίες τους για το 2010,
γ) εμφανίζει τους αύξοντες αριθμούς (1-120) και τις
    ηλικίες των ατόμων, κατά φθίνουσα σειρά ως προς
    τις ηλικίες.

Λύση

    Αλγόριθμος ΑΣΚ
    Για λ από 1 μέχρι 120
        Διάβασε ΕΓΕΝ[λ]
        Νο[λ] <-- λ
    Τέλος_επανάληψης
    Για λ από 1 μέχρι 120
        Η[λ] <-- 2010-ΕΓΕΝ[λ]
    Τέλος_επανάληψης
    Για λ από 2 μέχρι 120
         Για κ από 120 μέχρι λ με_βήμα -1
              Αν Η[κ-1] < Η[κ] τότε
                   Β1 <-- Η[κ-1]
                   Η[κ-1] <-- Η[κ]
                   Η[κ] <-- Β1
                   Β2 <-- Νο[κ-1]
                   Νο[κ-1] <-- Νο[κ]
                   Νο[κ] <-- Β2
              Τέλος_αν
         Τέλος_επανάληψης
    Τέλος_επανάληψης
    Για λ από 1 μέχρι 120
        Εμφάνισε Νο[λ], Η[λ]
    Τέλος_επανάληψης

    Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου