Τρίτη, 27 Ιουλίου 2010

Άσκηση: Κλιμακωτός+Για..από..μέχρι

Σε ένα σούπερ μάρκετ δίνεται η δυνατότητα αγοράς
εμφιαλωμένων νερών μάρκας ΝΝΝ με κλιμακωτή χρέωση
για τους πελάτες. Πιο συγκεκριμένα, η χρέωση για κάθε εξάδα
εμφιαλωμένων νερών καθορίζεται από τον πίνακα που
ακολουθεί:
         Πλήθος εξάδων                        Τιμή εξάδας (ευρώ)
         Από 1 έως και 5                                      1,75
         Από 6 έως και 9                                      1,62
         Από 10 και πάνω                                     1,51
Την πρώτη ημέρα της προσφοράς, 85 πελάτες προμηθεύτηκαν εξάδες
νερού ΝΝΝ από το συγκεκριμένο σουπερ μάρκετ. Γράψτε πρόγραμμα
το οποίο:
α) διαβάζει πόσες εξάδες νερό αγόρασε κάθε πελάτης,
β) υπολογίζει και εμφανίζει τη χρέωση κάθε πελάτη.

Λύση

       ΠΡΟΓΡΑΜΜΑ ΝΕΡΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Εξ, κ
              ΠΡΑΓΜΑΤΙΚΕΣ: Χρ
       ΑΡΧΗ
              ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 85
                     ΔΙΑΒΑΣΕ Εξ
                     ΑΝ Εξ <= 5 ΤΟΤΕ
                          Χρ <-- Εξ*1.75
                     ΑΛΛΙΩΣ_ΑΝ Εξ <= 9 ΤΟΤΕ
                          Χρ <-- 5*1.75+(Εξ-5)*1.62
                     ΑΛΛΙΩΣ
                          Χρ <-- 5*1.75+4*1.62+(Εξ-9)*1.51
                     ΤΕΛΟΣ_ΑΝ
                     ΓΡΑΨΕ 'Χρέωση', κ, ' πελάτη:', Χρ, ' ευρώ'
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου