Σάββατο, 17 Ιουλίου 2010

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο
έναν ακέραιο πίνακα Χ[7, 18] και αντιγράφει τα στοιχεία
της:
α) 3ης γραμμής στον ακέραιο πίνακα Υ[18],
β) 8ης στήλης στον ακέραιο πίνακα  Ζ[7].

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΑΝΤΙΓΡ(Χ, Υ, Ζ)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Χ[7, 18], Υ[18], Ζ[7], κ
     ΑΡΧΗ
           ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 18
                Υ[κ] <-- Χ[3, κ]
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 7
                Ζ[κ] <-- Χ[κ, 8]
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου