Δευτέρα, 19 Ιουλίου 2010

'Ασκηση : Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει τις τιμές πώλησης
κάποιων ηλεκτρονικών παιχνιδιών (η είσοδος δεδομένων
ολοκληρώνεται μόλις δοθεί η απάντηση 'ΝΑΙ' στην
υποβαλλόμενη προς το χρήστη ερώτηση 'Ολοκληρώθηκε;')
και υπολογίζει:
α) τη μέση τιμή πώλησης,
β) τη μεγαλύτερη τιμή πώλησης και τον αύξοντα αριθμό
     του παιχνιδιού στον οποίο αντιστοιχεί (θεωρείστε ότι
     οι τιμές πώλησης είναι διαφορετικές μεταξύ τους),
γ) το ποσοστό (%) των παιχνιδιών που είχαν τιμή πώλησης
    τουλάχιστον 35 ευρώ.

Λύση

    Αλγόριθμος  Παιχνίδια
    Αθρ <-- 0
    Π35 <-- 0
    ΜΑΧ <-- -1000
    Πληθ <-- 0
    Αρχή_επανάληψης
         Διάβασε Τιμή
         Πληθ <-- Πληθ+1
         Αθρ <-- Αθρ+Τιμή
         Αν Τιμή > ΜΑΧ τότε
               ΜΑΧ <-- Τιμή
               Νο <-- Πληθ
         Τέλος_αν
         Αν Τιμή >= 35 τότε
               Π35 <-- Π35+1
         Τέλος_αν
         Εμφάνισε 'Ολοκληρώθηκε;'
         Διάβασε Χ
    Μέχρις_ότου Χ = 'ΝΑΙ'
    ΜΟ <-- Αθρ/Πληθ
    ΠΟΣ <-- 100*Π35/Πληθ
    Εμφάνισε ΜΟ, ΜΑΧ, Νο, ΠΟΣ
    Τέλος Παιχνίδια

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου