Παρασκευή, 2 Ιουλίου 2010

Άσκηση : Διορθώστε τα λάθη

Ο παρακάτω αλγόριθμος έχει ως στόχο του
να υπολογίσει το ποσοστό (%) των 400
μαθητών ενός σχολείου που έχουν
γεννηθεί πριν το 1997.
      Αλγόριθμος Μαθη-τές
      ρ <-- 1
      Για λ από 1 μέχρι 400
          Διάβασε 'Ετος
          Αν Έτος > 1997 τότε
                ρ = ρ+1
          Τέλοςαν
     Τέλος
     Ποσοστό <-- 100*400/ρ
     Δείξε Ποσοστό
     Τέλος_αλγορίθμου
α) Διορθώστε τα λάθη που υπάρχουν.
β) Ποιά από τα λάθη αυτά είναι συντακτικά και
    ποιά λογικά;

Λύση

α)
     Αλγόριθμος Μαθητές
      ρ <--0
      Για λ από 1 μέχρι 400
          Διάβασε 'Ετος
          Αν Έτος < 1997 τότε
                ρ <-- ρ+1
          Τέλος_αν
     Τέλος_επανάληψης
     Ποσοστό <-- 100*ρ/400
     Εμφάνισε Ποσοστό
     Τέλος Μαθητές

β)
      Συντακτικά
            Μαθη-τές, ρ = ρ+1, Τέλοςαν, Τέλος, Δείξε,
            Τέλος_αλγορίθμου
      Λογικά
            ρ <-- 1, Ποσοστό <-- 100*400/ρ, Έτος > 1997

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου