Σάββατο, 24 Ιουλίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών με υπόδειγμα πίνακα τιμών (Όσο+Αν..τότε..αλλιώς)

Δίνεται το παρακάτω τμήμα προγράμματος στο οποίο έχουν
αριθμηθεί οι γραμμές:
   1   ΔΙΑΒΑΣΕ Χ, Υ
   2   κ <-- 21-Χ
   3   λ <-- Υ+4
   4   ΟΣΟ κ < λ ΕΠΑΝΑΛΑΒΕ
   5        ΑΝ   κ^2+1 < 39 ΤΟΤΕ
   6                μ <-- κ+λ+7
   7        ΑΛΛΙΩΣ
   8                μ <-- κ-λ+3
   9        ΤΕΛΟΣ_ΑΝ
 10         ν <-- 4*μ
 11         κ <-- κ+3
 12   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Επίσης δίνεται υπόδειγμα πίνακα με συμπληρωμένες
τις αρχικές τιμές των μεταβλητών Χ, Υ.

     Αριθμός        Χ        Υ       κ        λ      μ      ν
     γραμμής
          1               18       6
         ...                ...       ...     ...       ...      ...     ...

Να μεταφέρετε τον πίνακα στο τετράδιό σας και εκτε-
λώντας το τμήμα προγράμματος, να τον συμπληρώσετε
με αρχικές τιμές Χ = 18 και Υ = 6 που ήδη φαίνονται στον
πίνακα. Για κάθε εντολή εκχώρησης τιμής που εκτελείται
να γράψετε σε νέα γραμμή του πίνακα:
   α. Τον αριθμό της γραμμής που βρίσκεται η εντολή
       (στην πρώτη στήλη)
   β. Τη νέα τιμή  της μεταβλητής η οποία επηρεάζεται από
       την εντολή (στην αντίστοιχη στήλη).

Λύση

     Χ = 18, Υ = 6
     κ = 21-Χ = 21-18 = 3
     λ = Υ+4 = 6+4 = 10
     1η επανάληψη
            Αφού κ^2+1 < 39 = 3^2+1 < 39 = 10 < 39 = ΑΛΗΘΗΣ
                 μ = κ+λ+7 = 3+10+7 = 20
            ν = 4*μ = 4*20 = 80
            κ = κ+3 = 3+3 = 6
     2η επανάληψη
            Αφού κ^2+1 < 39 = 6^2+1 < 39 = 37 < 39 = ΑΛΗΘΗΣ
                 μ = κ+λ+7 = 6+10+7 = 23
            ν = 4*μ = 4*23 = 92
            κ = κ+3 = 6+3 = 9
     3η επανάληψη
            Αφού κ^2+1 < 39 = 9^2+1 < 39 = 82 < 39 = ΨΕΥΔΗΣ
                 μ = κ-λ+3 = 9-10+3 = 2
            ν = 4*μ = 4*2 = 8
            κ = κ+3 = 9+3 = 12
     Αφού κ < λ = 12 < 10 = ΨΕΥΔΗΣ, η ΟΣΟ τερματίζεται.
     Κατά συνέπεια ο πίνακας συμπληρωμένος έχει ως εξής:
      
     Αριθμός        Χ        Υ       κ        λ      μ      ν
     γραμμής
          1               18       6
          2                                   3
          3                                            10
          6                                                    20
         10                                                            80
         11                                  6
          6                                                    23
         10                                                            92
         11                                  9
          8                                                   2
         10                                                            8
         11                                12

        

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου