Παρασκευή, 30 Ιουλίου 2010

Άσκηση : φρουρός+ψηφία

Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει τριψήφιους θετικούς ακέραιους αριθμούς
    (η είσοδος δεδομένων τερματίζεται μόλις δοθεί
     ένας μη θετικός τριψήφιος ακέραιος),
β) υπολογίζει το άθροισμα των τετραγώνων των
    ψηφίων τους.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΨΗΦ
      ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Χ, ΕΚ, ΔΕΚ, ΜΟΝ, ΑΠΟΤ
      ΑΡΧΗ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                 ΔΙΑΒΑΣΕ Χ
                 ΑΝ (Χ >= 100) ΚΑΙ (Χ <= 999) ΤΟΤΕ
                      ΕΚ <-- Χ DIV 100
                      ΔΕΚ <-- ( Χ MOD 100) DIV 10
                      MON <-- (Χ MOD 100) MOD 10
                      ΑΠΟΤ <-- ΕΚ^2+ΔΕΚ^2+ΜΟΝ^2
                      ΓΡΑΨΕ ΑΠΟΤ
                 ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ (Χ < 100) Ή (Χ > 999)
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου