Δευτέρα, 9 Αυγούστου 2010

Άσκηση : δυσδιάστατος και μονοδιάστατος πίνακας

Γράψτε πρόγραμμα το οποίο:
α) διαβάζει τα ονόματα 10 ταμειακών υπαλλήλων μιας
    τράπεζας και τα καταχωρεί σε μονοδιάστατο πίνακα,
β) διαβάζει το συνολικό ποσό με το οποίο έκλεισε καθένας
    από τους παραπάνω υπάλληλους το ταμείο του για κάθε
    εργάσιμη ημέρα της περασμένης εβδομάδας, και καταχωρεί
    τα δεδομένα σε δυσδιάστατο πίνακα,
γ) υπολογίζει και εμφανίζει:
    * τις συνολικό εβδομαδιαίο ποσό με το οποίο έκλεισε
       το ταμείο του κάθε υπαλλήλου,
    * το όνομα του υπαλλήλου που πέτυχε το μεγαλύτερο
       συνολικό εβδομαδιαίο ποσό (θεωρείστε ότι είναι μονα-
       δικός),
    * το συνολικό ποσό που είχε (στο κλείσιμο) η τράπεζα σε
       όλα τα ταμεία της, για κάθε μέρα ξεχωριστά.

Λύση

    ΠΡΟΓΡΑΜΜΑ Τράπεζα
    ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: κ, λ, Θ
        ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[10]
        ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ[10, 5], σ, ΜΑΧ, SUM[10]
    ΑΡΧΗ
        ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
             ΔΙΑΒΑΣΕ ΟΝ[κ]
             ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 5
                  ΔΙΑΒΑΣΕ ΠΟΣΟ[κ, λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
             σ <-- 0
             ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 5
                  σ <-- σ+ΠΟΣΟ[κ, λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             SUM[κ] <-- σ
             ΓΡΑΨΕ ΟΝ[κ], ' εβδομαδιαίο ποσό :', σ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΜΑΧ <-- SUM[1]
        Θ <-- 1
        ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ 10
            ΑΝ SUM[κ] > ΜΑΧ ΤΟΤΕ
                 ΜΑΧ <-- SUM[κ]
                 Θ <-- κ
            ΤΕΛΟΣ_ΑΝ 
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Μέγιστο εβδομαδιαίο ποσό από τον :', ΟΝ[Θ]
        ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 5
            σ <-- 0
            ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
                  σ <-- σ+ΠΟΣΟ[κ, λ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΡΑΨΕ 'Σύνολο για ', λ, ' ημέρα :', σ 
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου