Τετάρτη, 4 Αυγούστου 2010

Άσκηση : Εξαφανίστε τους περιττούς ελέγχους

Ξαναγράψτε το παρακάτω σύνολο εντολών
εξαφανίζοντας τους περιττούς ελέγχους
     Αν α <  0 τότε
         Εμφάνισε α
     αλλιώς_αν (α >= 0) ΚΑΙ (α < 199) τότε
         Εμφάνισε -α
     αλλιώς_αν (α >= 199) ΚΑΙ (α < 234) τότε
         Εμφάνισε α+1
     αλλιώς
           Αν α >= 234 τότε
                 Εμφάνισε 1-α
           Τέλος_αν
     Τέλος_αν

Λύση

     Αν α <  0 τότε
         Εμφάνισε α
     αλλιώς_αν α < 199 τότε
         Εμφάνισε -α
     αλλιώς_αν α < 234 τότε
         Εμφάνισε α+1
     αλλιώς
         Εμφάνισε 1-α
     Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου