Κυριακή, 29 Αυγούστου 2010

Άσκηση: φρουρός

Γράψτε αλγόριθμο που διαβάζει τη χώρα προέλευσης
κάποιων ανθρώπων (η είσοδος ολοκληρώνεται μόλις
δοθεί η λέξη 'ΠΟΥΘΕΝΑ') και υπολογίζει:
α) το συνολικό πλήθος των ανθρώπων που εξετάστηκαν,
β) πόσοι από αυτούς ήταν έλληνες,
γ) το ποσοστό (%) από αυτούς που δεν ήταν έλληνες.

Λύση

      Αλγόριθμος Χώρες
      Πλήθος <-- 0
      Ελ <-- 0
      Αρχή_επανάληψης
          Διάβασε Χώρα
          Αν Χώρα < > 'ΠΟΥΘΕΝΑ' τότε
               Πλήθος <-- Πλήθος+1
               Αν Χώρα = 'ΕΛΛΑΔΑ' τότε
                    Ελ <-- Ελ+1          

               Τέλος_αν
          Τέλος_αν
      Μέχρις_ότου Χώρα = 'ΠΟΥΘΕΝΑ'
      Αν Πλήθος > 0 τότε
           ΠΟΣ <-- 100*(Πλήθος-Ελ)/Πλήθος
           Εμφάνισε Πλήθος, Ελ, ΠΟΣ
      αλλιώς
           Εμφάνισε 'Δε δόθηκαν δεδομένα!'
      Τέλος_αν
      Τέλος Χώρες

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου