Πέμπτη, 5 Αυγούστου 2010

Άσκηση : Γέμισμα δυσδιάστατου πίνακα

Ποιό είναι το περιεχόμενο του πίνακα Β[2, 3] μετά
την εκτέλεση των παρακάτω εντολών;
      Για κ από 1 μέχρι 2
           Για λ από 1 μέχρι 3
               Αν κ+λ < 4 τότε
                    Β[κ, λ] <-- κ+λ
               αλλιώς 
                    Β[κ, λ] <-- λ-κ
               Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης

Λύση

      κ = 1
            λ = 1
                Αφού κ+λ < 4 = 1+1 < 4 = 2 < 4 = Αληθής
                       Β[κ, λ] = Β[1, 1] = κ+λ = 1+1 = 2
            λ = 2
                 Αφού κ+λ < 4 = 1+2 < 4 = 3 < 4 = Αληθής
                       Β[κ, λ] = Β[1, 2] = κ+λ = 1+2 = 3
            λ = 3
                 Αφού κ+λ < 4 = 1+3 < 4 = 4 < 4 = Ψευδής
                       Β[κ, λ] = Β[1, 3] = λ-κ = 3-1 = 2
       κ = 2
            λ = 1
                Αφού κ+λ < 4 = 2+1 < 4 = 3 < 4 = Αληθής
                       Β[κ, λ] = Β[2, 1] = κ+λ = 2+1 = 3
            λ = 2
                Αφού κ+λ < 4 = 2+2 < 4 = 4 < 4 = Ψευδής
                       Β[κ, λ] = Β[2, 2] = λ-κ = 2-2 = 0
            λ = 3
                Αφού κ+λ < 4 = 2+3 < 4 = 5 < 4 = Ψευδής
                       Β[κ, λ] = Β[2, 3] = λ-κ = 3-2 = 1
     Κατά συνέπεια το περιεχόμενο του Β είναι:
               2           3           2
               3           0           1
            

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου