Δευτέρα, 30 Αυγούστου 2010

Άσκηση σε δυσδιάστατο πίνακα (μέγιστα/ελάχιστα ανά γραμμή και ανά στήλη)

Θεωρείστε τον πραγματικό πίνακα ΠΟΣ[7, 4] που περιέχει
τα ποσοστά πληρότητας (%) τεσσάρων αεροπορικών πτήσεων
Αθήνας-Ηρακλείου για κάθε μέρα της εβδομάδας που πέρασε.
Γράψτε αλγόριθμο που υπολογίζει και εμφανίζει:
α) το μεγαλύτερο ποσοστό πληρότητας για κάθε ημέρα
    ξεχωριστά και τον αύξοντα αριθμό (1-4) της πτήσης
    στην οποία καταγράφηκε (θεωρείστε ότι είναι μοναδική),
β) το μικρότερο ποσοστό πληρότητας για κάθε πτήση
    ξεχωριστά και τον αύξοντα αριθμό (1-7) της ημέρας στην
    οποία καταγράφηκε (θεωρείστε ότι είναι μοναδική).

Λύση

     Αλγόριθμος Πτήσεις
     Δεδομένα // ΠΟΣ //
     Για λ από 1 μέχρι 7
         ΜΑΧ <-- ΠΟΣ[λ, 1]
         ΑΑΜΑΧ <-- 1
         Για μ από 2 μέχρι 4
             Αν ΠΟΣ[λ, μ] > ΜΑΧ τότε
                  ΜΑΧ <-- ΠΟΣ[λ, μ]
                  ΑΑΜΑΧ <-- μ
             Τέλος_αν
         Τέλος_επανάληψης
         Εμφάνισε ΜΑΧ, ΑΑΜΑΧ
     Τέλος_επανάληψης
     Για μ από 1 μέχρι 4
         ΜΙΝ <-- ΠΟΣ[1, μ]
         ΑΑΜΙΝ <-- 1
         Για λ από 2 μέχρι 7
             Αν ΠΟΣ[λ, μ] < ΜΙΝ τότε
                  ΜΙΝ <-- ΠΟΣ[λ, μ]
                  ΑΑΜΙΝ <-- λ
             Τέλος_αν
         Τέλος_επανάληψης
         Εμφάνισε ΜΙΝ, ΑΑΜΙΝ
     Τέλος_επανάληψης
     Τέλος Πτήσεις

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου