Σάββατο, 7 Αυγούστου 2010

Άσκηση: αναζήτηση σε μονοδιάστατους πίνακες

Θεωρήστε τους ακόλουθους πίνακες:
   * ΜΑΡΚΕΣ[12] : που περιέχει τις μάρκες 12 αυτοκινήτων
   * ΜΟΝΤΕΛΑ[12] : που περιέχει τα μοντέλα των αυτοκινήτων
                                αυτών
   * ΟΔΗΓΟΙ[12] : που περιέχει τα ονόματα των οδηγών των
                            αυτοκινήτων αυτών
Γράψτε αλγόριθμο που, με δεδομένους τους παραπάνω πίνακες
α) διαβάζει μια μάρκα και ένα μοντέλο,
β) εξετάζει αν τα παραπάνω δεδομένα αντιστοιχούν σε κάποιο από τα
    12 αυτοκίνητα,
γ) αν η απάντηση στο ερώτημα β) είναι καταφατική, εμφανίζει το
    όνομα του οδηγού (σε διαφορετική περίπτωση κατάλληλο ενημε-
    ρωτικό  μήνυμα).

Λύση

     Αλγόριθμος αυτο
     Δεδομένα // ΜΑΡΚΕΣ, ΜΟΝΤΕΛΑ, ΟΔΗΓΟΙ //
     Διάβασε Μάρκα, Μοντέλο
     λ <-- 1
     φ <-- Ψευδής
     Όσο (λ <= 12) ΚΑΙ (φ = Ψευδής) επανάλαβε
           Αν (ΜΑΡΚΕΣ[λ] = Μάρκα) ΚΑΙ (ΜΟΝΤΕΛΑ[λ] = Μοντέλο)
           τότε
                φ <-- Αληθής
                θ <-- λ
           αλλιώς
                λ <-- λ+1
           Τέλος_αν
     Τέλος_επανάληψης
     Αν φ = Αληθής τότε
           Εμφάνισε 'Οδηγός είναι ο :', ΟΔΗΓΟΙ[θ]
     αλλιώς
           Εμφάνισε 'Δεν υπάρχει κανένα τέτοιο αυτοκίνητο!'
     Τέλος_αν
     Τέλος αυτο

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου