Δευτέρα, 9 Αυγούστου 2010

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παραμέτρους:
* την ακέραια μεταβλητή Υ (δυνατές τιμές 0 ή 1)
* την αλφαριθμητική μεταβλητή Π (δυνατές τιμές
   Χ ή Α)
και επιστρέφει την τιμή:
* -1, αν Υ = 0 και Π = 'Χ'
* 0, αν Υ = 0 και Π = 'Α'
* 1, αν Υ = 1 και Π = 'Χ'
* 2, αν Υ = 1 και Π = 'Α'

Λύση

   ΣΥΝΑΡΤΗΣΗ Φ(Υ, Π) : ΑΚΕΡΑΙΑ
   ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Υ
        ΧΑΡΑΚΤΗΡΕΣ: Π
   ΑΡΧΗ
        ΑΝ Υ = 0 ΤΟΤΕ
             ΑΝ Π = 'Χ' ΤΟΤΕ
                  Φ <-- -1
             ΑΛΛΙΩΣ
                  Φ <-- 0
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
             ΑΝ Π = 'Χ' ΤΟΤΕ
                  Φ <-- 1
             ΑΛΛΙΩΣ
                  Φ <-- 2
             ΤΕΛΟΣ_ΑΝ        
        ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου