Παρασκευή, 6 Αυγούστου 2010

Άσκηση : φρουρός

Γράψτε αλγόριθμο ο οποίος διαβάζει τη χωρητικότητα
(σε GB) κάποιων memory stick (η είσοδος δεδομένων
τερματίζεται όταν δοθεί ως τιμή ένας μη θετικός αριθμός)
και υπολογίζει:
α) το πλήθος των memory sticks που επεξεργαστήκατε,
β) πόσα memory sticks είχαν μέγεθος μεγαλύτερο από
    4 GB.

Λύση

     Αλγόριθμος Memory_sticks
     Πλήθος <-- 0
     Π4 <-- 0
     Αρχή_επανάληψης
         Διάβασε GB
         Αν GB > 0 τότε
             Πλήθος <-- Πλήθος+1
             Αν GB > 4 τότε
                  Π4 <-- Π4+1
             Τέλος_αν
         Τέλος_αν
     Μέχρις_ότου  GB <= 0
     Αποτελέσματα // Πλήθος, Π4 //
     Τέλος Memory_sticks

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου