Σάββατο, 7 Αυγούστου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Για+Για+Για)

Τι θα εμφανίσει το παρακάτω σύνολο εντολών
   Για κ από 3 μέχρι 9 με_βήμα 5
       Για λ από 12 μέχρι 4 με_βήμα -7
            Για μ από 20 μέχρι 31 με_βήμα 9
                 Εμφάνισε λ-μ+κ, λ+μ-κ
            Τέλος_επανάληψης
       Τέλος_επανάληψης
       Εμφάνισε κ+λ, κ-λ
   Τέλος_επανάληψης
   Εμφάνισε κ, λ, μ

Λύση

     κ = 3
          λ = 12
               μ = 20
                   Αφού λ-μ+κ = 12-20+3 = -5, λ+μ-κ = 12+20-3 = 29
                   η Εμφάνισε τυπώνει : -5    29
               μ = 29
                   Αφού λ-μ+κ = 12-29+3 = -14, λ+μ-κ = 12+29-3 =38
                   η Εμφάνισε τυπώνει : -14    38
               Η Για τερματίζεται με μ = 38

          λ = 5
               μ = 20
                   Αφού λ-μ+κ = 5-20+3 = -12, λ+μ-κ =5+20-3 = 22
                   η Εμφάνισε τυπώνει : -12    22

               μ = 29
                   Αφού λ-μ+κ =5-29+3 = -21, λ+μ-κ = 5+29-3 = 31
                   η Εμφάνισε τυπώνει : -21    31
               Η Για τερματίζεται με μ = 38        
          Η Για τερματίζεται με λ = -2
          Αφού κ+λ = 3+(-2) = -1, κ-λ = 3-(-2) = 5
          η Εμφάνισε τυπώνει : -1    5
     κ = 8
          λ = 12
               μ = 20
                   Αφού λ-μ+κ = 12-20+8 = 0, λ+μ-κ = 12+20-8 = 24
                   η Εμφάνισε τυπώνει : 0    24
               μ = 29
                   Αφού λ-μ+κ = 12-29+8 = -9, λ+μ-κ = 12+29-8 =33
                   η Εμφάνισε τυπώνει : -9    33
               Η Για τερματίζεται με μ = 38

          λ = 5
               μ = 20
                   Αφού λ-μ+κ = 5-20+8 = -7, λ+μ-κ =5+20-8 = 17
                   η Εμφάνισε τυπώνει : -7    17

               μ = 29
                   Αφού λ-μ+κ =5-29+8 = -16, λ+μ-κ = 5+29-8 = 26
                   η Εμφάνισε τυπώνει : -16    26
               Η Για τερματίζεται με μ = 38        
          Η Για τερματίζεται με λ = -2
          Αφού κ+λ = 8+(-2) = 6, κ-λ = 8-(-2) = 10
          η Εμφάνισε τυπώνει : 6    10

     Η Για τερματίζεται με κ = 13.
     Η Εμφάνισε τυπώνει :      13     -2     38

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου