Πέμπτη, 5 Αυγούστου 2010

Άσκηση μετατροπής Για σε α) Όσο και β) Μέχρις_ότου

Ξαναγράψτε το παρακάτω σύνολο εντολών
     α <-- 0
     Για λ από 20 μέχρι Μ^2 με_βήμα Α_Τ(ν)
          α <-- α+λ
     Τέλος_επανάληψης
 με  α) Όσο..επανάλαβε β) Μέχρις_ότου

Λύση

α)
     α <-- 0
     λ <-- 20
     Όσο λ <= Μ^2 επανάλαβε
         α <-- α+λ
         λ <-- λ+Α_Τ(ν)
     Τέλος_επανάληψης

    
β)
     α <-- 0
     Αν Μ^2 >= 20 τότε
         λ <-- 20
         Αρχή_επανάληψης
             α <-- α+λ
             λ <-- λ+Α_Τ(ν)
         Μέχρις_ότου λ > Μ^2
     Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου