Πέμπτη, 26 Αυγούστου 2010

Άσκηση: Κλιμακωτός+Φρουρός

Σε ένα κατάστημα αθλητικών ειδών, τα μπαλάκια του
πινγκ πονγκ έχουν την ακόλουθη κλιμακωτή χρέωση:
       Πλήθος από μπαλάκια            Κόστος ανά μπαλάκι
          Από 1 έως και 3                              1.1 ευρώ
          Από 4 έως και 10                             0.9 ευρώ
          Από 11 και πάνω                              0.78 ευρώ
Γράψτε πρόγραμμα το οποίο:
α) διαβάζει πόσα μπαλάκια πινγκ πονγκ επιθυμεί κάθε πελάτης
    του παραπάνω καταστήματος (η είσοδος δεδομένων ολοκλη-
    ρώνεται μόλις δοθεί μια μη θετική τιμή),
β) υπολογίζει και εμφανίζει:
    * τη χρέωση του κάθε πελάτη,
    * το συνολικό πλήθος των πελατών.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΠΙΝΓΚ_ΠΟΝΓΚ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Μπαλ, Πλήθος
            ΠΡΑΓΜΑΤΙΚΕΣ: Χ
      ΑΡΧΗ
            Πλήθος <-- 0
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                 ΔΙΑΒΑΣΕ Μπαλ
                 ΑΝ Μπαλ > 0 ΤΟΤΕ
                      Πλήθος <-- Πλήθος+1
                      ΑΝ Μπαλ <= 3 ΤΟΤΕ
                            Χ <-- Μπαλ*1.1
                      ΑΛΛΙΩΣ_ΑΝ Μπαλ <= 10 ΤΟΤΕ
                            Χ <-- 3*1.1+(Μπαλ-3)*0.9
                      ΑΛΛΙΩΣ
                            Χ <-- 3*1.1+7*0.9+(Μπαλ-10)*0.78
                      ΤΕΛΟΣ_ΑΝ
                      ΓΡΑΨΕ Χ
                 ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Μπαλ <= 0
            ΓΡΑΨΕ Πλήθος
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου