Κυριακή, 1 Αυγούστου 2010

Άσκηση : δυσδιάστατος πίνακας(μέσοι όροι ανά γραμμή+μέσοι όροι ανά στήλη)

Στα πλαίσια τουριστικής μελέτης καταγράφεται το
πλήθος των τουριστών για τους τρεις μήνες του καλο-
καιριού που επισκέφθηκαν 15 περιοχές της χώρας μας.
Γράψτε πρόγραμμα το οποίο:
α) διαβάζει το πλήθος των τουριστών ανά περιοχή και
    ανά μήνα και καταχωρεί τα δεδομένα αυτά σε κατάλ-
    ληλο πίνακα (δεν απαιτείται έλεγχος της εγκυρότητας
    των δεδομένων),
β) υπολογίζει και εμφανίζει:
    * το μέσο όρο του πλήθους των τουριστών ανά περιοχή,
    * το μέσο όρο του πλήθους των τουριστών ανά μήνα.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΤΟΥΡΙΣΤΕΣ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: κ, λ, ΠΛΗΘ[15, 3], σ
            ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
      ΑΡΧΗ
            ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 15
                ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 3
                     ΔΙΑΒΑΣΕ ΠΛΗΘ[κ, λ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 15
                σ <-- 0
                ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 3
                     σ <-- σ+ΠΛΗΘ[κ, λ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΜΟ <-- σ/3
                ΓΡΑΨΕ 'Μέσος όρος για', κ, ' περιοχή:', ΜΟ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 3
                σ <-- 0
                ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 15
                     σ <-- σ+ΠΛΗΘ[κ, λ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΜΟ <-- σ/15
                ΓΡΑΨΕ 'Μέσος όρος για', λ, ' μήνα:', ΜΟ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου