Παρασκευή, 6 Αυγούστου 2010

Άσκηση μετατροπής Μέχρις_ότου σε α) Όσο και β) Για

Ξαναγράψτε το παρακάτω σύνολο εντολών
      γ <-- 1
      κ <-- 210
      Αρχή_επανάληψης
           γ <-- γ*(κ-2)^3
           κ <-- κ-6
      Μέχρις_ότου κ < 70
χρησιμοποιώντας την εντολή:
α) Όσο..επανάλαβε
β) Για..από..μέχρι

Λύση

α)
      γ <-- 1
      κ <-- 210
      Όσο κ >= 70 επανάλαβε
           γ <-- γ*(κ-2)^3
           κ <-- κ-6
      Τέλος_επανάληψης

β)
      γ <-- 1
      Για κ από 210 μέχρι 70 με_βήμα -6
           γ <-- γ*(κ-2)^3
      Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου