Σάββατο, 21 Αυγούστου 2010

Άσκηση : Απλοποίηση εντολών

Αν η τιμή εισόδου είναι ακεραίου τύπου, απλοποιήστε το
παρακάτω σύνολο εντολών
    Αρχή_επανάληψης
         Διάβασε κ
    Μέχρις_ότου (κ >= 0) ΚΑΙ (κ < 100) ΚΑΙ (κ < > 0)
    Αν (κ > 98) Ή (κ > 99) τότε
          Εμφάνισε 'α'
    αλλιώς_αν κ > 59 τότε
          Εμφάνισε 'β'
    αλλιώς_αν κ > 0 τότε
          Εμφάνισε 'γ'
    αλλιώς
          Εμφάνισε 'δ'
    Τέλος_αν

Απάντηση

    Αρχή_επανάληψης
         Διάβασε κ
    Μέχρις_ότου (κ > 0) ΚΑΙ (κ < 100)
    Αν κ = 99 τότε
          Εμφάνισε 'α'
    αλλιώς_αν κ > 59 τότε
          Εμφάνισε 'β'
    αλλιώς
          Εμφάνισε 'γ'

    Τέλος_αν

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου