Τρίτη, 3 Αυγούστου 2010

Άσκηση: Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει το είδος της ταινίας
(Π - περιπέτεια, Κ - κωμωδία, Α - αστυνομικό,
Ι - ιστορικό, Θ - Θρίλερ) που παίζεται σε καθένα από
τους 11 κινηματογράφους μιας πόλης, καθώς και την
αντίστοιχη τιμή του εισιτηρίου, και υπολογίζει:
α) το ποσοστό (%) των ταινιών που είναι περιπέτειες,
β) πόσες ταινίες είναι θρίλερ,
γ) το μέσο όρο τιμής εισιτηρίου για τις κωμωδίες.

Λύση

      Αλγόριθμος Κινηματ
      Περ <-- 0
      Θρ <-- 0
      σ <-- 0
      Κωμ <-- 0
      Για λ από 1 μέχρι 11
           Διάβασε Είδος
           Διάβασε Τιμή
           Αν Είδος = 'Π' τότε
                Περ <-- Περ+1
           Τέλος_αν
           Αν Είδος = 'Θ' τότε
                Θρ <-- Θρ+1
           Τέλος_αν
           Αν Είδος = 'Κ' τότε
                 Κωμ <-- Κωμ+1
                 σ <-- σ+Τιμή
           Τέλος_αν
      Τέλος_επανάληψης
      ΠΟΣ <-- 100*Περ/11
      Εμφάνισε ΠΟΣ, Θρ
      Αν Κωμ > 0 τότε
            ΜΟ <-- σ/Κωμ
            Εμφάνισε ΜΟ
      αλλιώς
            Εμφάνισε 'Δεν παίζεται πουθενά κωμωδία!'
      Τέλος_αν
      Τέλος Κινηματ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου