Κυριακή, 8 Αυγούστου 2010

Άσκηση σε δυσδιάστατο πίνακα

Ένα εμπορικό κατάστημα διαθέτει προς πώληση μπλούζες
και πουκάμισα από 6 διαφορετικές μάρκες.Γράψτε αλγόριθμο
που:
α) διαβάζει τις τιμές πώλησης καθενός από τα παραπάνω
    ρούχα και τις καταχωρεί σε δυσδιάστατο πίνακα 6Χ2
    ( η πρώτη στήλη αφορά τις μπλούζες και η δεύτερη τα
    πουκάμισα),
β) υπολογίζει και εμφανίζει:
    * τη μέση τιμή πώλησης για την 5η μάρκα,
    * τη μέση τιμή πώλησης  των πουκάμισων,
    * τη μεγαλύτερη τιμή πώλησης, τον αύξοντα αριθμό (1-6)
       της μάρκας και το είδος του ρούχου (μπλούζα ή πουκάμισο)
       στο οποίο αντιστοιχεί.
Παρατήρηση: Όλες οι τιμές πώλησης είναι διαφορετικές
μεταξύ τους.

Λύση

     Αλγόριθμος Ρούχα
     Για κ από 1 μέχρι 6
          Για λ από 1 μέχρι 2
                Διάβασε Τιμή[κ, λ]
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     σ <-- 0
     Για λ από 1 μέχρι 2
           σ <-- σ+Τιμή[5, λ]
     Τέλος_επανάληψης
     ΜΟ5 <-- σ/2
     Εμφάνισε ΜΟ5
     σ <-- 0
     Για κ από 1 μέχρι 6
          σ <-- σ+Τιμή[κ, 2]
     Τέλος_επανάληψης
     ΜΟ2 <-- σ/6
     Εμφάνισε ΜΟ2
     ΜΑΧ <-- Τιμή[1, 1]
     Μάρκα <-- 1
     Είδος <-- 1    
     Για κ από 1 μέχρι 6
         Για λ από 1 μέχρι 2
              Αν Τιμή[κ, λ] > ΜΑΧ τότε
                    ΜΑΧ <-- Τιμή[κ, λ]
                    Μάρκα <-- κ
                    Είδος <-- λ
              Τέλος_αν
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Αν Είδος = 1 τότε
           ΕιδΜΑΧ <-- 'μπλούζα'
     αλλιώς
           ΕιδΜΑΧ <-- 'πουκάμισο'
     Τέλος_αν
     Εμφάνισε ΜΑΧ, Μάρκα, ΕιδΜΑΧ
     Τέλος Ρούχα

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου