Τετάρτη, 25 Αυγούστου 2010

Άσκηση: Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που
α) διαβάζει τους χρόνους σε λεπτά που θέλουν για να μαγειρευτούν
    11 διαφορετικά φαγητά, καθώς και τις επωνυμίες των φαγητών
    αυτών,
β) και εντοπίζει την επωνυμία του φαγητού που θέλει:
    * τον περισσότερο χρόνο για να μαγειρευτεί,
    * το λιγότερο χρόνο για να μαγειρευτεί.
Παρατήρηση : Οι χρόνοι που θέλουν για να μαγειρευτούν τα
φαγητά είναι διαφορετικοί μεταξύ τους.

Λύση

     Αλγόριθμος Φαγητά
     Διάβασε Χρόνος
     Διάβασε Επωνυμία
     ΜΑΧ <-- Χρόνος
     ΕπωνΜΑΧ <-- Επωνυμία
     ΜΙΝ <-- Χρόνος
     ΕπωνΜΙΝ <-- Επωνυμία
     Για λ από 2 μέχρι 11
          Διάβασε Χρόνος
          Διάβασε Επωνυμία
          Αν Χρόνος > ΜΑΧ τότε
               ΜΑΧ <-- Χρόνος
               ΕπωνΜΑΧ <-- Επωνυμία
          Τέλος_αν
          Αν Χρόνος < ΜΙΝ τότε
               ΜΙΝ <-- Χρόνος
               ΕπωνΜΙΝ <-- Επωνυμία
          Τέλος_αν
     Τέλος_επανάληψης
     Αποτελέσματα // ΕπωνΜΑΧ, ΕπωνΜΙΝ //
     Τέλος Φαγητά

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου