Σάββατο, 13 Νοεμβρίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση (Όσο+Όσο)

Τι θα εμφανίσει το παρακάτω σύνολο εντολών, αν οι τιμές
εισόδου είναι 2 και 7;
     Διάβασε  ν, μ
     Όσο μ > 0 επανάλαβε
           Όσο ν < 5 επανάλαβε
                Εμφάνισε μ^(ν-1), μ+ν > 8
                ν <-- ν+2
           Τέλος_επανάληψης
           Εμφάνισε 2*μ+3*ν
           μ <-- μ-4
           ν <-- μ+1
     Τέλος_επανάληψης
     Εμφάνισε μ, ν

Λύση

     ν = 2, μ = 7
     1η επανάληψη της εξωτερικής Όσο
           1η επανάληψη της εσωτερικής Όσο
                    Αφού μ^(ν-1) = 7^(2-1) = 7^1 = 7 και 
                    μ+ν > 8 = 7+2 > 8 = 9> 8 = Αληθής, 
                    η Εμφάνισε τυπώνει:
                            7      Αληθής
                    ν = ν+2 = 2+2 = 4
           2η επανάληψη της εσωτερικής Όσο
                    Αφού μ^(ν-1) = 7^(4-1) = 7^3 = 343  και 
                    μ+ν > 8 = 7+4 > 8 = 11 > 8 = Αληθής, 
                    η Εμφάνισε τυπώνει:
                            343      Αληθής
                    ν = ν+2 = 4+2 = 6
           Η εσωτερική Όσο τερματίζεται με ν = 6.
           Αφού 2*μ+3*ν = 2*7+3*6 = 14+18 = 32, 
           η Εμφάνισε τυπώνει:
                  32
           μ = μ-4 = 7-4 = 3
           ν = μ+1 = 3+1 = 4
     2η επανάληψη της εξωτερικής Όσο
           1η επανάληψη της εσωτερικής Όσο
                    Αφού μ^(ν-1) = 3^(4-1) = 3^3 = 27 και 
                    μ+ν > 8 = 3+4 > 8 = 7 > 8 = Ψευδής, 
                    η Εμφάνισε τυπώνει:
                            27     Ψευδής
                    ν = ν+2 = 4+2 = 6
           Η εσωτερική Όσο τερματίζεται με ν = 6.
           Αφού 2*μ+3*ν = 2*3+3*6 = 6+18 = 24, 
           η Εμφάνισε τυπώνει:
                  24
           μ = μ-4 = 3-4 = -1
           ν = μ+1 = -1+1 = 0
     Η εξωτερική Όσο τερματίζεται.
     Η Εμφάνισε τυπώνει:
              -1      0

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου