Τετάρτη, 10 Νοεμβρίου 2010

Άσκηση : Εμφωλευμένα Για+μέγιστο+ελάχιστο

Γράψτε αλγόριθμο που διαβάζει:
α) τις επωνυμίες 15 εστιατορίων και τις μηνιαίες εισπράξεις
    τους τα τελευταία πέντε χρόνια (από 2005 έως και 2009),
β) υπολογίζει και εμφανίζει :
    * την επωνυμία του εστιατορίου που πέτυχε τη μεγαλύτερη
       μηνιαία είσπραξη, τον αύξοντα αριθμό του μήνα (1-12)
       που σημειώθηκε το γεγονός αυτό και  το έτος στο οποίο
       αντιστοιχεί,
    * την επωνυμία του εστιατορίου που πέτυχε τη μικρότερη
       μηνιαία είσπραξη, τον αύξοντα αριθμό του μήνα (1-12)
       που σημειώθηκε το γεγονός αυτό και  το έτος στο οποίο
       αντιστοιχεί.
Παρατηρήσεις
Ι. Όλες οι μηνιαίες εισπράξεις είναι διαφορετικές μεταξύ
   τους.
ΙΙ. Ο αλγόριθμος πρέπει να διασφαλίζει την εγκυρότητα των
     εισερχόμενων δεδομένων και συγκεκριμένα ότι:
    * οι επωνυμίες είναι διαφορετικές από το κενό διάστημα,
    * οι μηνιαίες εισπράξεις είναι θετικοί αριθμοί που δεν
       υπερβαίνουν το 5600.

Λύση

       Αλγόριθμος ΕΣΤ
       Μεγ <-- -1111
       Μικ <-- 5601
       Για κ από 1 μέχρι 15
              Αρχή_επανάληψης
                  Διάβασε Εστ
              Μέχρις_ότου Εστ < > '  '
             Για λ από 1 μέχρι 5
                   Για μ από 1 μέχρι 12
                         Αρχή_επανάληψης
                               Διάβασε Εισπ
                         Μέχρις_ότου (Εισπ > 0) ΚΑΙ (Εισπ <= 5600)
                         Αν Εισπ > Μεγ τότε
                               Μεγ <-- Εισπ
                               ΕστΜεγ <-- Εστ
                               ΧρΜεγ <-- 2004+λ
                               ΜηνΜεγ <-- μ
                         Τέλος_αν
                         Αν Εισπ < Μικ τότε
                               Μικ <-- Εισπ
                               ΕστΜικ <-- Εστ
                               ΧρΜικ <-- 2004+λ
                               ΜηνΜικ <-- μ
                         Τέλος_αν
                   Τέλος_επανάληψης
             Τέλος_επανάληψης
       Τέλος_επανάληψης
       Εμφάνισε ΕστΜεγ, ΧρΜεγ, ΜηνΜεγ
       Εμφάνισε ΕστΜικ, ΧρΜικ, ΜηνΜικ
       Τέλος ΕΣΤ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου