Κυριακή, 7 Νοεμβρίου 2010

Άσκηση : Μονοδιάστατοι πίνακες (ΜΟ+Μέγιστο+Μετρητής ιδιότητας)

Γράψτε αλγόριθμο που:
α) διαβάζει τα ονόματα 15 νομών της Ελλάδας και τους
    πληθυσμούς τους, καταχωρώντας τα δεδομένα αυτά
    σε κατάλληλους πίνακες,
β) υπολογίζει και εμφανίζει:
    * το μέσο πληθυσμό ανά νομό,
    * το όνομα του πληθυσμού με το μεγαλύτερο πληθυσμό,
    * πόσοι νομοί είχαν πληθυσμό μεγαλύτερο από 180000.

Λύση

     Αλγόριθμος Νομοί
     Για λ από 1 μέχρι 15
          Διάβασε Νομ[λ]
          Διάβασε Πληθ[λ]
     Τέλος_επανάληψης
     σ <-- 0
     Φ <-- 0
     Μεγ <-- -100
     Για λ από μέχρι 15
          Αν Πληθ[λ] > Μεγ τότε
               Μεγ <-- Πληθ[λ]
               ΝοΜεγ <-- Νομ[λ]
          Τέλος_αν
          σ <-- σ+Πληθ[λ]
          Αν Πληθ[λ] > 180000 τότε
                Φ <-- Φ+1
          Τέλος_αν   
     Τέλος_επανάληψης
     ΜΟ <-- σ/15
     Εμφάνισε ΜΟ, ΝοΜεγ, Φ
     Τέλος Νομοί

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου