Παρασκευή, 19 Νοεμβρίου 2010

Άσκηση : Μενού επιλογών

Γράψτε αλγόριθμο που παρέχει το ακόλουθο μενού
λειτουργιών
     1. Υπολογισμός του ποσοστού των αρτίων αριθμών
          από 1 έως και Ν
     2. Υπολογισμός πλήθους περιττών από 1 έως και Ν
     3. Υπολογισμός μέσου όρου Ν τυχαίων θετικών αριθμών
     4. Έξοδος
Αν η επιλογή του χρήστη είναι 1 ή 2 ή 3, διαβάζεται
ένας θετικός αριθμός Ν,  γίνεται ο αντίστοιχος υπολογισμός
και εμφανίζονται τα αποτελέσματα στην οθόνη. Όταν η
επιλογή είναι 4 (και μόνο τότε) ο αλγόριθμος τερματίζεται.
Παρατηρήσεις
Ι. Αν η επιλογή είναι 3, ο αλγόριθμος διαβάζει Ν τιμές
   εισόδου, διασφαλίζοντας ότι είναι θετικοί αριθμοί.
ΙΙ. Ο αλγόριθμος πρέπει να διασφαλίζει την εγκυρότητα των
     εισερχόμενων δεδομένων.

Λύση

      Αλγόριθμος Μενού
      Αρχή_επανάληψης
           Εμφάνισε '1. Ποσοστό αρτίων από 1 έως και Ν'
           Εμφάνισε '2. Πλήθος περιττών από 1 έως και Ν'
           Εμφάνισε '3. Μέσος όρος Ν τυχαίων θετικών'
           Εμφάνισε '4. Έξοδος'
           Αρχή_επανάληψης
                 Εμφάνισε 'Δώσε επιλογή:'
                 Διάβασε Επ
           Μέχρις_ότου (Επ >= 1) ΚΑΙ (Επ <= 4)
           Αν Επ < > 4 τότε
                Αρχή_επανάληψης
                      Διάβασε Ν
                Μέχρις_ότου Ν > 0
           Τέλος_αν
           Αν Επ = 1 τότε
                Αρτ <-- 0
                Για λ από 1 μέχρι Ν
                    Αν λ mod 2 = 0 τότε
                         Αρτ <-- Αρτ+1
                    Τέλος_αν
                Τέλος_επανάληψης
                ΠΟΣ <-- 100*Αρτ/Ν
                Εμφάνισε ΠΟΣ
           αλλιώς_αν Επ = 2 τότε
                Περ <-- 0
                Για λ από 1 μέχρι Ν
                    Αν λ mod 2 = 1 τότε
                         Περ <-- Περ+1
                    Τέλος_αν
                Τέλος_επανάληψης
                Εμφάνισε Περ
           αλλιώς_αν Επ = 3 τότε
                σ <-- 0
                Για λ από 1 μέχρι Ν
                    Αρχή_επανάληψης
                        Διάβασε Χ
                    Μέχρις_ότου Χ > 0

                    σ <-- σ+Χ
                Τέλος_επανάληψης
                ΜΟ <-- σ/Ν
                Εμφάνισε
ΜΟ
          αλλιώς   ! Επ = 4
                Εμφάνισε 'Τερματισμός λειτουργιών'
          Τέλος_αν  
      Μέχρις_ότου Επ = 4
      Τέλος Μενού

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου