Παρασκευή, 12 Νοεμβρίου 2010

Άσκηση : Δυσδιάστατοι πίνακες (αθροίσματα ανά γραμμή+στήλη)

Γράψτε αλγόριθμο που :
α) διαβάζει το πλήθος των πελατών που εξυπηρετούν 5
     ταμίες μιας τράπεζας κάθε εργάσιμη ημέρα του Φεβρουαρίου
     και καταχωρεί τα δεδομένα αυτά στον ακέραιο πίνακα
     ΠΕΛΑΤΕΣ[5, 20],
β) υπολογίζει και εμφανίζει:
    * το σύνολο των πελατών που εξυπηρέτησε κάθε 
       ταμίας (μέσα στο Φεβρουάριο),
    * το σύνολο των πελατών που εξυπηρετήθηκαν από
       όλους τους ταμίες, για κάθε εργάσιμη ημέρα ξεχωριστά.

Λύση

      Αλγόριθμος ΤΡΑΠΕΖΑ
      Για κ από 1 μέχρι 5
           Για λ από 1 μέχρι 20
                 Διάβασε ΠΕΛΑΤΕΣ[κ, λ]
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για κ από μέχρι 5
           σ <-- 0
           Για λ από μέχρι 20
                 σ <-- σ+ΠΕΛΑΤΕΣ[κ, λ]
           Τέλος_επανάληψης
           Εμφάνισε 'Σύνολο πελατών για ', κ , 'ταμία:', σ
      Τέλος_επανάληψης
       Για λ από μέχρι 20
           σ <-- 0
           Για κ από μέχρι 5
                 σ <-- σ+ΠΕΛΑΤΕΣ[κ, λ]
           Τέλος_επανάληψης
           Εμφάνισε 'Σύνολο πελατών για ', λ , 'ημέρα:', σ
      Τέλος_επανάληψης
      Τέλος ΤΡΑΠΕΖΑ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου