Σάββατο, 27 Νοεμβρίου 2010

Άσκηση : δυσδιάστατος πίνακας (επεξεργασία δοσμένης γραμμής και στήλης)

Θεωρήστε τον πίνακα ΠΤΗΣΗ[16, 12] που περιέχει τις
ώρες πτήσης 16 πιλότων για κάθε μήνα του προηγούμενου
έτους. Γράψτε αλγόριθμο που, με δεδομένο τον παραπάνω
πίνακα, υπολογίζει και εμφανίζει:
α) το ετήσιο σύνολο των ωρών πτήσης για τον 7ο πιλότο,
β) τον αύξοντα αριθμό (1-16) του πιλότου που έκανε τις
     περισσότερες ώρες πτήσης κατά τη διάρκεια του
     Φεβρουαρίου.

Λύση

     Αλγόριθμος Πιλότοι
     Δεδομένα // ΠΤΗΣΗ //
     σ <-- 0
     Για λ από 1 μέχρι 12
          σ <-- σ+ΠΤΗΣΗ[7, λ]
     Τέλος_επανάληψης
     Εμφάνισε σ
     Μεγ <-- ΠΤΗΣΗ[1, 2]
     ΑΑΜεγ <-- 1
     Για λ από 2 μέχρι 16
          Αν ΠΤΗΣΗ[λ, 2] > Μεγ τότε
                Μεγ <-- ΠΤΗΣΗ[λ, 2]
                ΑΑΜεγ <-- λ
          Τέλος_αν
     Τέλος_επανάληψης
      Εμφάνισε ΑΑΜεγ
     Τέλος Πιλότοι

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου