Παρασκευή, 12 Νοεμβρίου 2010

Άσκηση : Δυσδιάστατος πίνακας(μέγιστα ανά γραμμή+μετρητής ιδιότητας)

Θεωρείστε τον ακέραιο πίνακα ΕΦΗΜ[12, 120] που περιέχει το
πλήθος των φύλλων που πούλησαν 12 αθλητικές εφημερίδες τις
τελευταίες 120 ημέρες.Γράψτε αλγόριθμο που με δεδομένο τον
παραπάνω πίνακα, υπολογίζει και εμφανίζει:
α) τη μεγαλύτερο πλήθος πουλημένων φύλλων για κάθε εφημε-
    ρίδα και τον αύξοντα αριθμό (1-12) της ημέρας που σημειώθηκε
    το παραπάνω γεγονός,
β) πόσες εφημερίδες πούλησαν τουλάχιστον 15 φορές περισσότερα
    από 15000 φύλλα ημερησίως.

Λύση

        Αλγόριθμος ΑΘΛ
        Δεδομένα // ΕΦΗΜ //
        Φ15 <-- 0
        Για κ από 1 μέχρι 12
             ΜΑΧ <-- ΕΦΗΜ[κ, 1]
             ΗμερΜΑΧ <-- 1
             Πληθ <-- 0
             Για λ από 1 μέχρι 120
                   Αν ΕΦΗΜ[κ, λ] > ΜΑΧ τότε
                         ΜΑΧ <-- ΕΦΗΜ[κ, λ]
                         ΗμερΜΑΧ <-- λ
                   Τέλος_αν
                   Αν ΕΦΗΜ[κ, λ] > 15000 τότε
                         Πληθ <-- Πληθ+1
                   Τέλος_αν
             Τέλος_επανάληψης
             Εμφάνισε ΜΑΧ, ΗμερΜΑΧ
             Αν Πληθ >= 15 τότε
                   Φ15 <-- Φ15+1
             Τέλος_αν
        Τέλος_επανάληψης
        Εμφάνισε Φ15
        Τέλος ΑΘΛ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου