Παρασκευή, 19 Νοεμβρίου 2010

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που :
α) διαβάζει τις τιμές πώλησης κάποιων βιβλίων (η είσοδος
     δεδομένων ολοκληρώνεται μόλις δοθεί ως τιμή ένας μη
     θετικός αριθμός),
β) υπολογίζει:
    * το πλήθος των βιβλίων που εξετάστηκαν,
    * το ποσοστό (%) των βιβλίων που είχαν τιμή πώλησης
       μεγαλύτερη από 12 ευρώ,
    * τη μέση τιμή πώλησης των βιβλίων.
Παρατήρηση
Αν δε δοθούν καθόλου δεδομένα, και τα τρία αποτελέσματα
πρέπει να γίνουν ίσα με -1.

Λύση

      ΔΙΑΔΙΚΑΣΙΑ Βιβλία(Πλήθος, ΠΟΣ, ΜΟ)
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Πλήθος, Φ
             ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ, Τιμή, ΠΟΣ, σ
      ΑΡΧΗ
             Πλήθος <-- 0
             Φ <-- 0
             σ <-- 0
             ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  ΔΙΑΒΑΣΕ Τιμή
                  ΑΝ Τιμή > 0 ΤΟΤΕ
                         Πλήθος <-- Πλήθος+1
                         σ <-- σ+Τιμή
                         ΑΝ Τιμή > 12 ΤΟΤΕ
                               Φ <-- Φ+1
                         ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΑΝ
             ΜΕΧΡΙΣ_ΟΤΟΥ Τιμή <= 0
             ΑΝ Πλήθος > 0 ΤΟΤΕ
                   ΠΟΣ <-- 100*Φ/Πλήθος
                   ΜΟ <-- σ/Πλήθος
             ΑΛΛΙΩΣ
                   Πλήθος <-- -1
                   ΠΟΣ <-- -1
                   ΜΟ <-- -1
             ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου