Δευτέρα, 1 Νοεμβρίου 2010

Ποιό είναι το περιεχόμενο του πίνακα

Δίνεται το παρακάτω σύνολο εντολών
     Για κ από 1 μέχρι 6
          Για μ από 1 μέχρι 6
               Αν κ = μ τότε 
                      Α[κ, μ] <-- 8
               αλλιώς_αν κ+μ = 7 τότε
                      Α[κ, μ] <-- 5
               αλλιώς
                      Α[κ, μ] <-- -1

               Τέλος_αν
          Τέλος_επανάληψης
     Τέλος_επανάληψης
Ποιό είναι το περιεχόμενο του πίνακα Α[6, 6] μετά την
εκτέλεση των παραπάνω εντολών;

Λύση

Παρατηρούμε ότι :
* τα στοιχεία της 1ης κύριας διαγωνίου παίρνουν την τιμή 8
* τα στοιχεία της 2ης κύριας διαγωνίου παίρνουν την τιμή5
* όλα τα υπόλοιπα στοιχεία παίρνουν την τιμή -1
Κατά συνέπεια το περιεχόμενο του Α είναι :

       8    -1   -1    -1     -1    5
      -1     8   -1    -1     5    -1
      -1    -1    8     5     -1   -1
      -1    -1    5      8    -1   -1
      -1     5    -1    -1     8    -1
       5    -1    -1    -1     -1    8

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου