Τετάρτη, 17 Νοεμβρίου 2010

Άσκηση : επεξεργασία δοσμένου πλήθους δεδομένων (Για..από..μέχρι)

Γράψτε αλγόριθμο που διαβάζει :
α) το πλήθος των εντολών 18 προγραμμάτων,
β) υπολογίζει και εμφανίζει:
    * το μέσο όρο εντολών ανά πρόγραμμα,
    * πόσα προγράμματα είχαν περισσότερες από 200
       εντολές,
    * το ποσοστό (%) των προγραμμάτων που είχαν
       το πολύ 120 εντολές.

Λύση

    Αλγόριθμος Προγ
    σ <-- 0
    φ1 <-- 0
    φ2 <-- 0
    Για λ από 1 μέχρι 18
         Διάβασε Εντ
         σ <-- σ+Εντ
         Αν Εντ > 200 τότε
               φ1 <-- φ1+1
         Τέλος_αν
         Αν Εντ <= 120 τότε
              φ2 <-- φ2+1
         Τέλος_αν
    Τέλος_επανάληψης
    ΜΟ <-- σ/18
    ΠΟΣ <-- 100*φ2/18
    Εμφάνισε ΜΟ, φ1, ΠΟΣ
    Τέλος Προγ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου