Κυριακή, 21 Νοεμβρίου 2010

Άσκηση: συγγραφή διαδικασίας

Σε ένα πάρτυ διασκεδάζουν 230 άτομα. Γράψτε διαδικασία
που δέχεται ως παράμετρο έναν ακέραιο πίνακα Η[230] που
περιέχει τις ηλικίες των ατόμων αυτών και υπολογίζει πόσα
από αυτά έχουν ηλικία 18, 19, 20, 21, ...., 46 έτη.

Λύση

      ΔΙΑΔΙΚΑΣΙΑ Ηλικίες(Η, Αποτ)
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Η[230], Αποτ[29], Θ, λ
      ΑΡΧΗ
            ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 29
                   Αποτ[λ] <-- 0
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΙΑ λ ΑΠΟ ΜΕΧΡΙ 230
                  ΑΝ (Η[λ] >= 18) ΚΑΙ (Η[λ] <= 46) ΤΟΤΕ
                      Θ <-- Η[λ]-17
                      Αποτ[Θ] <-- Αποτ[Θ]+1
                  ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου