Πέμπτη, 18 Νοεμβρίου 2010

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους ένα ακέραιο Ν
και μια λογική τιμή Τ και υπολογίζει:
    * το άθροισμα 1+2+3+...+Ν, αν Τ = ΑΛΗΘΗΣ
    * το γινόμενο 1 Χ 2 Χ ... Χ Ν, αν Τ = ΨΕΥΔΗΣ

Λύση

     ΣΥΝΑΡΤΗΣΗ ΑΠ(Ν, Τ) : ΑΚΕΡΑΙΑ
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Ν, Παρ, μ
            ΛΟΓΙΚΕΣ: Τ
     ΑΡΧΗ
            ΑΝ Τ = ΑΛΗΘΗΣ ΤΟΤΕ
                  Παρ <-- 0
                  ΓΙΑ μ ΑΠΟ ΜΕΧΡΙ Ν
                        Παρ <-- Παρ+μ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΛΛΙΩΣ
                  Παρ <-- 1
                  ΓΙΑ μ ΑΠΟ ΜΕΧΡΙ Ν
                        Παρ <-- Παρ*μ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΑΝ
            ΑΠ <-- Παρ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου