Τετάρτη, 17 Νοεμβρίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει το πλήθος των έγκυρων, των
άκυρων και των λευκών ψηφοδελτίων σε κάθε εκλογικό
τμήμα της χώρας (η είσοδος δεδομένων ολοκληρώνεται
μόλις δοθεί η απάντηση  ΌΧΙ' στην υποβαλλόμενη προς το
χρήστη ερώτηση 'Υπάρχει άλλο εκλογικό τμήμα;'), υπολογίζει
και εμφανίζει:
α) τον αύξοντα αριθμό του εκλογικού τμήματος με το μικρότερο
    ποσοστό (%) έγκυρων ψηφοδελτίων,
β) το ποσοστό (%) των εκλογικών τμημάτων που είχαν τουλάχιστον
    3% ποσοστό άκυρων ψηφοδελτίων,
γ) το μέσο όρο λευκών ψηφοδελτίων ανά εκλογικό τμήμα.

Λύση

       Αλγόριθμος Εκλογές
       Μικ <-- 101
       Πληθ <-- 0
       Φ3 <-- 0
       σ <-- 0
       Αρχή_επανάληψης
            Διάβασε 'Εγκυρα, Άκυρα, Λευκά
            Πληθ <-- Πληθ+1
            Σύνολο <-- 'Εγκυρα+Άκυρα+Λευκά
            ΠοσΕγκ <-- 100*Έγκυρα/Σύνολο
            Αν ΠοσΕγκ < Μικ τότε
                 Μικ <-- ΠοσΕγκ
                 ΑΑΜικ <-- Πληθ
            Τέλος_αν
            ΠοσΑκυρ <-- 100*Άκυρα/Σύνολο
            Αν ΠοσΑκυρ >= 3 τότε
                 Φ3 <-- Φ3+1
            Τέλος_αν
            σ <-- σ+Λευκά
            Εμφάνισε 'Υπάρχει άλλο εκλογικό τμήμα;'
            Διάβασε Απ
       Μέχρις_ότου Απ = 'ΟΧΙ'
       ΜΟΛ <-- σ/Πληθ
       ΠΟΣ <-- 100*Φ3/Πληθ
       Εμφάνισε ΑΑΜικ, ΠΟΣ, ΜΟΛ
       Τέλος Εκλογές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου